summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrth <rth@138bc75d-0d04-0410-961f-82ee72b054a4>2012-01-05 01:35:25 +0000
committerrth <rth@138bc75d-0d04-0410-961f-82ee72b054a4>2012-01-05 01:35:25 +0000
commitb33ca042ba186f30ca27740719a9a7188f1fa419 (patch)
treeed66bfe3f00e27ed5b2a77a416a23ffa7ea37ba2 /configure.ac
parentd1a21c3587f1f9190f36491fc74f47d4417279fd (diff)
downloadgcc-b33ca042ba186f30ca27740719a9a7188f1fa419.tar.gz
PR bootstrap/51072
* configure.ac: Disable libitm if c++ is not enabled. * configure: Rebuild. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@182899 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9fee56378e1..b97c5051044 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1982,6 +1982,14 @@ case ,${enable_languages},:${enable_objc_gc} in
;;
esac
+# Disable libitm if we're not building C++
+case ,${enable_languages}, in
+ *,c++) ;;
+ *)
+ noconfigdirs="$noconfigdirs target-libitm"
+ ;;
+esac
+
# Remove the entries in $skipdirs and $noconfigdirs from $configdirs,
# $build_configdirs and $target_configdirs.
# If we have the source for $noconfigdirs entries, add them to $notsupp.