summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrth <rth@138bc75d-0d04-0410-961f-82ee72b054a4>2011-11-08 16:06:25 +0000
committerrth <rth@138bc75d-0d04-0410-961f-82ee72b054a4>2011-11-08 16:06:25 +0000
commit298c66d96719f98e870b7deedeac9b4611849194 (patch)
tree257f6d91d2117a12fa1ed620ee8ebfeabd03a360 /configure.ac
parenta1942f0c9db4c65c6b61950cbda4d92e449a972b (diff)
downloadgcc-298c66d96719f98e870b7deedeac9b4611849194.tar.gz
Check for libitm support at top-level.
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@181168 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 8 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 4bca6d82f46..0a30880ef98 100644
--- a/configure.ac
+++ b/configure.ac
@@ -493,22 +493,15 @@ if test x$enable_libgomp = x ; then
esac
fi
-# Disable libitm on non POSIX hosted systems.
-if test x$enable_libitm = x ; then
- # Enable libitm by default on hosted POSIX systems.
- case "${target}" in
- *-*-linux* | *-*-gnu* | *-*-k*bsd*-gnu)
- ;;
- *-*-netbsd* | *-*-freebsd* | *-*-openbsd*)
- ;;
- *-*-solaris2* | *-*-sysv4* | *-*-irix6* | *-*-osf* | *-*-hpux11*)
- ;;
- *-*-darwin* | *-*-aix*)
- ;;
- *)
+# Disable libitm on unsupported hosted systems.
+if test x$enable_libitm = x; then
+ AC_MSG_CHECKING([for libitm support])
+ if (. ${srcdir}/libitm/configure.tgt; test -n "$UNSUPPORTED"); then
+ AC_MSG_RESULT([no])
noconfigdirs="$noconfigdirs target-libitm"
- ;;
- esac
+ else
+ AC_MSG_RESULT([yes])
+ fi
fi
# Disable libssp for some systems.