summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authortschwinge <tschwinge@138bc75d-0d04-0410-961f-82ee72b054a4>2014-12-15 10:54:43 +0000
committertschwinge <tschwinge@138bc75d-0d04-0410-961f-82ee72b054a4>2014-12-15 10:54:43 +0000
commit67cedda8d6cb6825870b324d30575d00462913b7 (patch)
treef1633194d56de9a4f584d7032e71716884ae880f /configure.ac
parentaa3c6b9684577757b210e7999d92fbf77407b0a9 (diff)
downloadgcc-67cedda8d6cb6825870b324d30575d00462913b7.tar.gz
Build machinery cleanup.
* configure.ac (--enable-as-accelerator-for): Don't set ENABLE_AS_ACCELERATOR_FOR. Update all users. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@218744 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index fd1bdf0f506..91c9a726338 100644
--- a/configure.ac
+++ b/configure.ac
@@ -289,9 +289,7 @@ esac
AC_ARG_ENABLE(as-accelerator-for,
[AS_HELP_STRING([--enable-as-accelerator-for=ARG],
[build as offload target compiler.
- Specify offload host triple by ARG])],
-ENABLE_AS_ACCELERATOR_FOR=$enableval,
-ENABLE_AS_ACCELERATOR_FOR=no)
+ Specify offload host triple by ARG])])
AC_ARG_ENABLE(offload-targets,
[AS_HELP_STRING([--enable-offload-targets=LIST],
@@ -470,7 +468,7 @@ AC_HELP_STRING([[--enable-liboffloadmic[=ARG]]],
*)
AC_MSG_ERROR([--enable-liboffloadmic=no/host/target]) ;;
esac],
-[if test "${ENABLE_AS_ACCELERATOR_FOR}" != "no"; then
+[if test x"$enable_as_accelerator_for" != x; then
case "${target}" in
*-intelmic-* | *-intelmicemul-*)
enable_liboffloadmic=target