summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormrs <mrs@138bc75d-0d04-0410-961f-82ee72b054a4>2013-07-10 20:52:45 +0000
committermrs <mrs@138bc75d-0d04-0410-961f-82ee72b054a4>2013-07-10 20:52:45 +0000
commit3b6e6f124e647d7eb73e25db1e1629fc428bc8be (patch)
tree053afeb70f9434b7c512f12a454544792a6e2a31 /configure.ac
parent73f353d043742ab1d4b019d88a4e81641f931087 (diff)
downloadgcc-3b6e6f124e647d7eb73e25db1e1629fc428bc8be.tar.gz
2013-07-10 Jack Howarth <howarth@bromo.med.uc.edu>
PR target/57792 * configure.ac: Use --with-sysroot=\"`xcrun --show-sdk-path`\" on darwin13 and later. * configure: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@200886 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bec489fc395..f689866be0c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2850,6 +2850,13 @@ if test x${is_cross_compiler} = xyes ; then
target_configargs="--with-cross-host=${host_noncanonical} ${target_configargs}"
fi
+# Pass --with-sysroot on darwin without SDK in /
+case "${target}" in
+ x86_64-*-darwin1[[3-9]]*)
+ host_configargs="--with-sysroot=\"`xcrun --show-sdk-path`\" ${host_configargs}"
+ ;;
+esac
+
# Default to --enable-multilib.
if test x${enable_multilib} = x ; then
target_configargs="--enable-multilib ${target_configargs}"