summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorhp <hp@138bc75d-0d04-0410-961f-82ee72b054a4>2011-06-22 19:40:45 +0000
committerhp <hp@138bc75d-0d04-0410-961f-82ee72b054a4>2011-06-22 19:40:45 +0000
commit5ab7e1231a4f515f39454e9a303c34adb17a94fd (patch)
treefe3d2b5d3bde6b22cc43f173f37f62518ae64aab /configure.ac
parent8c4a7fb7093a4ee71e610e3f1c8ae9f76a74c47f (diff)
downloadgcc-5ab7e1231a4f515f39454e9a303c34adb17a94fd.tar.gz
PR47836
PR23656 PR47733 PR49247 * configure.ac (target_libraries): Remove target-libiberty. Remove case-statement setting skipdirs=target-libiberty for multiple targets. Remove checking target_configdirs and removing target-libiberty but keeping target-libgcc if otherwise empty. * Makefile.def (target_modules): Don't add libiberty. (dependencies): Remove all traces of target-libiberty. * configure, Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@175304 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac69
1 files changed, 1 insertions, 68 deletions
diff --git a/configure.ac b/configure.ac
index 6ed08dacae1..b88a8212a39 100644
--- a/configure.ac
+++ b/configure.ac
@@ -149,9 +149,8 @@ libgcj="target-libffi \
# these libraries are built for the target environment, and are built after
# the host libraries and the host tools (which may be a cross compiler)
-#
+# Note that libiberty is not a target library.
target_libraries="target-libgcc \
- target-libiberty \
target-libgloss \
target-newlib \
target-libgomp \
@@ -490,51 +489,6 @@ case "${target}" in
;;
esac
-# Disable target libiberty for some systems.
-case "${target}" in
- *-*-kaos*)
- # Remove unsupported stuff on all kaOS configurations.
- skipdirs="target-libiberty"
- ;;
- *-*-netbsd*)
- # Skip some stuff on all NetBSD configurations.
- noconfigdirs="$noconfigdirs target-libiberty"
- ;;
- *-*-netware*)
- noconfigdirs="$noconfigdirs target-libiberty"
- ;;
- *-*-rtems*)
- skipdirs="${skipdirs} target-libiberty"
- ;;
- *-*-tpf*)
- noconfigdirs="$noconfigdirs target-libiberty"
- ;;
- *-*-vxworks*)
- noconfigdirs="$noconfigdirs target-libiberty"
- ;;
- sh*-*-pe|mips*-*-pe|*arm-wince-pe)
- noconfigdirs="$noconfigdirs target-libiberty"
- ;;
- arm*-*-symbianelf*|arm*-*-linux-androideabi)
- noconfigdirs="$noconfigdirs target-libiberty"
- ;;
- avr-*-*)
- noconfigdirs="$noconfigdirs target-libiberty"
- ;;
- m68hc11-*-*|m6811-*-*|m68hc12-*-*|m6812-*-*)
- noconfigdirs="$noconfigdirs target-libiberty"
- ;;
- picochip-*-*)
- noconfigdirs="$noconfigdirs target-libiberty"
- ;;
- mips*-sde-elf*)
- skipdirs="$skipdirs target-libiberty"
- ;;
- ip2k-*-*)
- noconfigdirs="$noconfigdirs target-libiberty"
- ;;
-esac
-
# Disable libstdc++-v3 for some systems.
case "${target}" in
*-*-vxworks*)
@@ -1965,27 +1919,6 @@ for dir in . $skipdirs $noconfigdirs ; do
fi
done
-# Sometimes the tools are distributed with libiberty but with no other
-# libraries. In that case, we don't want to build target-libiberty.
-# Don't let libgcc imply libiberty either.
-if test -n "${target_configdirs}" ; then
- libgcc=
- others=
- for i in `echo ${target_configdirs} | sed -e s/target-//g` ; do
- if test "$i" = "libgcc"; then
- libgcc=target-libgcc
- elif test "$i" != "libiberty" ; then
- if test -r $srcdir/$i/configure ; then
- others=yes;
- break;
- fi
- fi
- done
- if test -z "${others}" ; then
- target_configdirs=$libgcc
- fi
-fi
-
# Quietly strip out all directories which aren't configurable in this tree.
# This relies on all configurable subdirectories being autoconfiscated, which
# is now the case.