summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrguenth <rguenth@138bc75d-0d04-0410-961f-82ee72b054a4>2009-10-22 08:56:00 +0000
committerrguenth <rguenth@138bc75d-0d04-0410-961f-82ee72b054a4>2009-10-22 08:56:00 +0000
commit24d0cd27dec59383f97c63d664badcf8b4a17d8b (patch)
tree95458b6cff72ef253f9e1a47fc83cbb1a141c5df /configure.ac
parentf30e488d09d7e3a1055346d2e5b4b167959dbd63 (diff)
downloadgcc-24d0cd27dec59383f97c63d664badcf8b4a17d8b.tar.gz
2009-10-22 Richard Guenther <rguenther@suse.de>
* configure.ac: Do not set LIBS for ppl/cloog checks. Disable cloog if the ppl version check failed. Move flags saving before setting in libelf check. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@153447 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 5 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 431d89cdb86..34c34959b87 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1523,12 +1523,10 @@ case $with_ppl in
ppllibs=
;;
yes)
- LIBS="$ppllibs $LIBS"
;;
*)
ppllibs="-L$with_ppl/lib -lppl_c -lppl -lgmpxx"
pplinc="-I$with_ppl/include $pplinc"
- LIBS="$ppllibs $LIBS"
;;
esac
if test "x$with_ppl_include" != x; then
@@ -1536,12 +1534,10 @@ if test "x$with_ppl_include" != x; then
fi
if test "x$with_ppl_lib" != x; then
ppllibs="-L$with_ppl_lib -lppl_c -lppl -lgmpxx"
- LIBS="$ppllibs $LIBS"
fi
if test "x$with_ppl$with_ppl_include$with_ppl_lib" = x && test -d ${srcdir}/ppl; then
ppllibs='-L$$r/$(HOST_SUBDIR)/ppl/.libs -L$$r/$(HOST_SUBDIR)/ppl/_libs -lppl_c -lppl -lgmpxx '
pplinc='-I$$r/$(HOST_SUBDIR)/ppl/include -I$$s/ppl/include '
- LIBS="$ppllibs $LIBS"
fi
AC_ARG_ENABLE(ppl-version-check,
@@ -1557,7 +1553,7 @@ if test "x$with_ppl" != "xno" -a "${ENABLE_PPL_CHECK}" = "yes"; then
#if PPL_VERSION_MAJOR != $ppl_major_version || PPL_VERSION_MINOR != $ppl_minor_version
choke me
#endif
- ], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([no]); ppllibs= ; pplinc= ])
+ ], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([no]); ppllibs= ; pplinc= ; with_ppl=no ])
CFLAGS="$saved_CFLAGS"
fi
@@ -1586,12 +1582,10 @@ case $with_cloog in
clooginc=
;;
yes)
- LIBS="$clooglibs $LIBS"
;;
*)
clooglibs="-L$with_cloog/lib -lcloog"
clooginc="-I$with_cloog/include -DCLOOG_PPL_BACKEND "
- LIBS="$clooglibs $LIBS"
;;
esac
if test "x$with_cloog_include" != x; then
@@ -1599,12 +1593,10 @@ if test "x$with_cloog_include" != x; then
fi
if test "x$with_cloog_lib" != x; then
clooglibs="-L$with_cloog_lib -lcloog"
- LIBS="$clooglibs $LIBS"
fi
if test "x$with_cloog$with_cloog_include$with_cloog_lib" = x && test -d ${srcdir}/cloog; then
clooglibs='-L$$r/$(HOST_SUBDIR)/cloog/.libs -L$$r/$(HOST_SUBDIR)/cloog/_libs -lcloog '
clooginc='-I$$r/$(HOST_SUBDIR)/cloog/include -I$$s/cloog/include -DCLOOG_PPL_BACKEND '
- LIBS="$clooglibs $LIBS"
fi
AC_ARG_ENABLE(cloog-version-check,
@@ -1644,6 +1636,10 @@ if test x"$enable_lto" = x"yes" ; then
AC_ARG_WITH(libelf_lib, [ --with-libelf-lib=PATH Specify the directory for the installed libelf library])
+ saved_CFLAGS="$CFLAGS"
+ saved_CPPFLAGS="$CPPFLAGS"
+ saved_LIBS="$LIBS"
+
case $with_libelf in
"")
libelflibs="-lelf"
@@ -1672,10 +1668,6 @@ if test x"$enable_lto" = x"yes" ; then
LIBS="$libelflibs $LIBS"
fi
- saved_CFLAGS="$CFLAGS"
- saved_CPPFLAGS="$CPPFLAGS"
- saved_LIBS="$LIBS"
-
CFLAGS="$CFLAGS $libelfinc"
CPPFLAGS="$CPPFLAGS $libelfinc"
LIBS="$LIBS $libelflibs"