summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrwild <rwild@138bc75d-0d04-0410-961f-82ee72b054a4>2009-09-21 19:24:40 +0000
committerrwild <rwild@138bc75d-0d04-0410-961f-82ee72b054a4>2009-09-21 19:24:40 +0000
commit9d447cf8e5c5b45cd1574904164f6227ffab47f5 (patch)
treef2ca0e8f1bd31f34e5d4a124e7c3ebb687cbcff8 /configure.ac
parent1907f70c065696a117a6909d7d24ecb04754d1fb (diff)
downloadgcc-9d447cf8e5c5b45cd1574904164f6227ffab47f5.tar.gz
Diagnose --enable-build-with-cxx --enable-bootstrap --enable-languages w/o c++
/* * configure.ac: Diagnose --enable-build-with-cxx bootstrap with --enable-languages not containing c++. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@151939 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f3d511973ce..a8fb3b79714 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2460,6 +2460,13 @@ case "$have_compiler:$host:$target:$enable_bootstrap" in
;;
esac
+case ",$enable_languages,:$ENABLE_BUILD_WITH_CXX:$enable_bootstrap" in
+ *,c++,*:yes:yes) ;;
+ *:yes:yes)
+ AC_MSG_ERROR([bootstrapping with --enable-build-with-cxx requires c++ in --enable-languages])
+ ;;
+esac
+
# Adjust the toplevel makefile according to whether bootstrap was selected.
case $enable_bootstrap in
yes)