summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrsandifo <rsandifo@138bc75d-0d04-0410-961f-82ee72b054a4>2007-03-21 20:09:15 +0000
committerrsandifo <rsandifo@138bc75d-0d04-0410-961f-82ee72b054a4>2007-03-21 20:09:15 +0000
commitd623d58787143a556c903aa2ef6c191b2b30316e (patch)
treefeaf56adf3851705f2004093fef9b5e85de76d6a /configure.ac
parent7619cb36a03de73a8dc4376d0c9eb2c6d95e74f3 (diff)
downloadgcc-d623d58787143a556c903aa2ef6c191b2b30316e.tar.gz
* configure.ac (TOPLEVEL_CONFIGURE_ARGUMENTS): Fix m4 quoting
of glob. Quote arguments with single quotes too. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@123117 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 16ff8d3ddf1..9c38fadfd94 100644
--- a/configure.ac
+++ b/configure.ac
@@ -92,7 +92,7 @@ set -- "$progname" "$@"
for ac_arg
do
case "$ac_arg" in
- *" "*|*" "*|*[\[\]\~\#\$\^\&\*\(\)\{\}\\\|\;\<\>\?]*)
+ *" "*|*" "*|*[[\[\]\~\#\$\^\&\*\(\)\{\}\\\|\;\<\>\?\']]*)
ac_arg=`echo "$ac_arg" | sed "s/'/'\\\\\\\\''/g"`
# if the argument is of the form -foo=baz, quote the baz part only
ac_arg=`echo "'$ac_arg'" | sed "s/^'\([[-a-zA-Z0-9]]*=\)/\\1'/"` ;;