summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorhp <hp@138bc75d-0d04-0410-961f-82ee72b054a4>2014-10-24 14:30:35 +0000
committerhp <hp@138bc75d-0d04-0410-961f-82ee72b054a4>2014-10-24 14:30:35 +0000
commitb85b703bc22e21cc917d0a0d92c3b5215ef86a3a (patch)
treebfd591dfa59e4835ad90c4e16b7eedeacd12d5d2 /configure.ac
parent5766e83ccf565c84b990897c12113c73ff88163f (diff)
downloadgcc-b85b703bc22e21cc917d0a0d92c3b5215ef86a3a.tar.gz
* configure.ac (build_configargs): Don't share config.cache between
build subdirs. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@216669 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index abfd038fa0b..573109277ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2922,8 +2922,10 @@ AC_ARG_VAR([target_configargs],
# For the build-side libraries, we just need to pretend we're native,
# and not use the same cache file. Multilibs are neither needed nor
-# desired.
-build_configargs="$build_configargs --cache-file=../config.cache ${baseargs}"
+# desired. We can't even use the same cache file for all build-side
+# libraries, as they're compiled differently; some with C, some with
+# C++ or with different feature-enabling options.
+build_configargs="$build_configargs --cache-file=./config.cache ${baseargs}"
# For host modules, accept cache file option, or specification as blank.
case "${cache_file}" in