summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorhjl <hjl@138bc75d-0d04-0410-961f-82ee72b054a4>2012-11-29 16:33:35 +0000
committerhjl <hjl@138bc75d-0d04-0410-961f-82ee72b054a4>2012-11-29 16:33:35 +0000
commit9e5b186b1778f5d7316218190693cab985d0930d (patch)
tree91a45d23dcabb925a214fc600966382a7ec92c7d /configure.ac
parent31631c5351145bb3a9a1152b2e10ad52c6b42a65 (diff)
downloadgcc-9e5b186b1778f5d7316218190693cab985d0930d.tar.gz
Add --with-build-config=bootstrap-asan support
* Makefile.def (target_modules): Add bootstrap=true and raw_cxx=true to libsanitizer. * configure.ac (bootstrap_target_libs): Add libsanitizer. * Makefile.in: Regenerated. * configure: Likewise. config/ * bootstrap-asan.mk: New file. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@193940 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 49f4f5dae88..a92ff3af8b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2433,6 +2433,11 @@ if echo " ${target_configdirs} " | grep " libgomp " > /dev/null 2>&1 ; then
bootstrap_target_libs=${bootstrap_target_libs}target-libgomp,
fi
+# If we are building libsanitizer, bootstrap it.
+if echo " ${target_configdirs} " | grep " libsanitizer " > /dev/null 2>&1 ; then
+ bootstrap_target_libs=${bootstrap_target_libs}target-libsanitizer,
+fi
+
# Determine whether gdb needs tk/tcl or not.
# Use 'maybe' since enable_gdbtk might be true even if tk isn't available
# and in that case we want gdb to be built without tk. Ugh!