summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorspop <spop@138bc75d-0d04-0410-961f-82ee72b054a4>2009-01-12 21:36:58 +0000
committerspop <spop@138bc75d-0d04-0410-961f-82ee72b054a4>2009-01-12 21:36:58 +0000
commit4aa0552b1e4d930c270c2c3630a19c8525e50181 (patch)
tree50198d31fd5fda65783a6aef4f4a9e20fed4b754 /configure.ac
parent9ae625ff4634167e2744b1c106e414354ee1b61c (diff)
downloadgcc-4aa0552b1e4d930c270c2c3630a19c8525e50181.tar.gz
2009-01-12 Sebastian Pop <sebastian.pop@amd.com>
PR tree-optimization/38515 * configure.ac (cloog-polylib): Removed. (with_ppl, with_cloog): Test for "no". * configure: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@143311 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 21 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 6efc633c308..3ab54a788a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1324,11 +1324,16 @@ AC_ARG_WITH(ppl, [ --with-ppl=PATH Specify prefix directory for the ins
AC_ARG_WITH(ppl_include, [ --with-ppl-include=PATH Specify directory for installed PPL include files])
AC_ARG_WITH(ppl_lib, [ --with-ppl-lib=PATH Specify the directory for the installed PPL library])
-if test "x$with_ppl" != x; then
- ppllibs="-L$with_ppl/lib -lppl_c -lppl -lgmpxx"
- pplinc="-I$with_ppl/include $pplinc"
- LIBS="$ppllibs $LIBS"
-fi
+case $with_ppl in
+ no)
+ ppllibs=
+ ;;
+ *)
+ ppllibs="-L$with_ppl/lib -lppl_c -lppl -lgmpxx"
+ pplinc="-I$with_ppl/include $pplinc"
+ LIBS="$ppllibs $LIBS"
+ ;;
+esac
if test "x$with_ppl_include" != x; then
pplinc="-I$with_ppl_include $pplinc"
fi
@@ -1373,18 +1378,18 @@ AC_ARG_WITH(cloog, [ --with-cloog=PATH Specify prefix directory for the i
plus --with-cloog-lib=PATH/lib])
AC_ARG_WITH(cloog_include, [ --with-cloog-include=PATH Specify directory for installed CLooG include files])
AC_ARG_WITH(cloog_lib, [ --with-cloog-lib=PATH Specify the directory for the installed CLooG library])
-AC_ARG_WITH(cloog-polylib, [ --with-cloog-polylib=PATH Specify prefix directory for the installed CLooG-PolyLib package])
-if test "x$with_cloog" != x; then
- clooglibs="-L$with_cloog/lib -lcloog"
- clooginc="-I$with_cloog/include -DCLOOG_PPL_BACKEND "
- LIBS="$clooglibs $LIBS"
-fi
-if test "x$with_cloog_polylib" != x; then
- clooglibs="-L$with_cloog/lib -lcloog"
- clooginc="-I$with_cloog/include "
- LIBS="$clooglibs $LIBS"
-fi
+case $with_cloog in
+ no)
+ clooglibs=
+ clooginc=
+ ;;
+ *)
+ clooglibs="-L$with_cloog/lib -lcloog"
+ clooginc="-I$with_cloog/include -DCLOOG_PPL_BACKEND "
+ LIBS="$clooglibs $LIBS"
+ ;;
+esac
if test "x$with_cloog_include" != x; then
clooginc="-I$with_cloog_include -DCLOOG_PPL_BACKEND "
fi