summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Merrill <jason@redhat.com>2015-05-26 08:29:13 -0400
committerJason Merrill <jason@gcc.gnu.org>2015-05-26 08:29:13 -0400
commit460704884ffa0cdd637b726ce53524c6a2c9ef79 (patch)
treeb2c58825207b709d6973d425a1a3e7f6d2d2c825 /configure.ac
parent13ccfea8fa39f448f5630274b868b3b8a3a448c1 (diff)
downloadgcc-460704884ffa0cdd637b726ce53524c6a2c9ef79.tar.gz
configure.ac: When bootstrapping with GCC, add -std=c++98 to CXX.
* configure.ac: When bootstrapping with GCC, add -std=c++98 to CXX. * configure: Regenerate. From-SVN: r223692
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4da04b76fdf..431cb170e16 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1442,6 +1442,12 @@ case "$have_compiler:$host:$target:$enable_bootstrap" in
;;
esac
+# When bootstrapping with GCC, build stage 1 in C++98 mode to ensure that a
+# C++98 compiler can still start the bootstrap.
+if test "$enable_bootstrap:$GXX" = "yes:yes"; then
+ CXX="$CXX -std=c++98"
+fi
+
# Used for setting $lt_cv_objdir
_LT_CHECK_OBJDIR