summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Pop <sebastian.pop@amd.com>2010-04-02 17:35:39 +0000
committerSebastian Pop <spop@gcc.gnu.org>2010-04-02 17:35:39 +0000
commit0333b9a65d1787b860a1ad0e0c4204fe71fa3ecf (patch)
treea8435cfb386c963315e84c7e3b3769043c6ff1ee /configure.ac
parent1cdaa211989e0de46e77f46d42367c42f9a0831c (diff)
downloadgcc-0333b9a65d1787b860a1ad0e0c4204fe71fa3ecf.tar.gz
Print "buggy but acceptable" when CLooG revision is less than 9.
2010-04-02 Sebastian Pop <sebastian.pop@amd.com> * configure.ac: Print "buggy but acceptable" when CLooG revision is less than 9. * configure: Regenerated. From-SVN: r157945
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 72407f86878..edad2b63e57 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1617,7 +1617,12 @@ if test "x$with_cloog" != "xno" -a "${ENABLE_CLOOG_CHECK}" = "yes"; then
#if CLOOG_VERSION_MAJOR != 0 || CLOOG_VERSION_MINOR != 15 || CLOOG_VERSION_REVISION < 5
choke me
#endif
- ], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([no]); clooglibs= ; clooginc= ])
+ ], AC_TRY_COMPILE([#include "cloog/cloog.h"],[
+ #if CLOOG_VERSION_MAJOR != 0 || CLOOG_VERSION_MINOR != 15 || CLOOG_VERSION_REVISION < 9
+ choke me
+ #endif
+ ], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([buggy but acceptable])]),
+ [AC_MSG_RESULT([no]); clooglibs= ; clooginc= ])
CFLAGS="$saved_CFLAGS"
fi