summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Biener <rguenther@suse.de>2013-01-14 15:01:13 +0000
committerRichard Biener <rguenth@gcc.gnu.org>2013-01-14 15:01:13 +0000
commitd0ad394c5e95de3ad312be53bd6399a679b3b27d (patch)
tree219645a4804abcaa9d6dc4dc693dbd4758a7a993 /configure.ac
parent7bb0199604cf8ba978b2fbfb751f2081faa64f87 (diff)
downloadgcc-d0ad394c5e95de3ad312be53bd6399a679b3b27d.tar.gz
configure.ac (cloog/isl): Also allow ISL 0.11.x and CLooG 0.18.0.
2013-01-14 Richard Biener <rguenther@suse.de> * configure.ac (cloog/isl): Also allow ISL 0.11.x and CLooG 0.18.0. * configure: Re-generate From-SVN: r195150
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 02720ee1b15..739cdc786cc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1606,8 +1606,11 @@ if test "x$with_isl" != "xno" &&
dnl Provide configure switches and initialize islinc & isllibs
dnl with user input.
ISL_INIT_FLAGS
- dnl The minimal version of ISL required for Graphite.
+ dnl The versions of ISL that work for Graphite
ISL_CHECK_VERSION(0,10)
+ if test "${gcc_cv_isl}" = no ; then
+ ISL_CHECK_VERSION(0,11)
+ fi
dnl Only execute fail-action, if ISL has been requested.
ISL_IF_FAILED([
AC_MSG_ERROR([Unable to find a usable ISL. See config.log for details.])])
@@ -1617,11 +1620,11 @@ if test "x$with_isl" != "xno" &&
dnl Provide configure switches and initialize clooginc & clooglibs
dnl with user input.
CLOOG_INIT_FLAGS
- dnl The minimal version of CLooG required for Graphite.
- dnl
- dnl If we use CLooG-Legacy, the provided version information is
- dnl ignored.
+ dnl The versions of CLooG that work for Graphite.
CLOOG_CHECK_VERSION(0,17,0)
+ if test "${gcc_cv_cloog}" = no ; then
+ CLOOG_CHECK_VERSION(0,18,0)
+ fi
dnl Only execute fail-action, if CLooG has been requested.
CLOOG_IF_FAILED([