summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKaveh R. Ghazi <ghazi@caip.rutgers.edu>2009-04-25 03:24:17 +0000
committerKaveh Ghazi <ghazi@gcc.gnu.org>2009-04-25 03:24:17 +0000
commit9e3eba15997699303768c9c7b6eee72f8a9ca294 (patch)
treefd56186e7966d8794ec9eca62bda22b371218f53 /configure.ac
parent569c72fc740316fc468b0dab64f2b72ad6dc5fbd (diff)
downloadgcc-9e3eba15997699303768c9c7b6eee72f8a9ca294.tar.gz
re PR bootstrap/39739 (Bootstrapping with in-tree mpfr-2.4.1 and --with-gmp=... errors)
PR bootstrap/39739 * configure.ac (extra_mpfr_configure_flags): Set and AC_SUBST. * Makefile.def (module=mpfr): Use extra_mpfr_configure_flags. * configure, Makefile.in: Regenerate. From-SVN: r146754
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4b123f409b1..0bb26e83a4a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1254,6 +1254,7 @@ fi
if test "x$with_gmp$with_gmp_include$with_gmp_lib" = x && test -d ${srcdir}/gmp; then
gmplibs='-L$$r/$(HOST_SUBDIR)/gmp/.libs -L$$r/$(HOST_SUBDIR)/gmp/_libs '"$gmplibs"
gmpinc='-I$$r/$(HOST_SUBDIR)/gmp -I$$s/gmp '"$gmpinc"
+ extra_mpfr_configure_flags='--with-gmp-build=$$r/$(HOST_SUBDIR)/gmp'
# Do not test the gmp version. Assume that it is sufficient, since
# it is in the source tree, and the library has not been built yet
# but it would be included on the link line in the version check below
@@ -1318,6 +1319,7 @@ fi
# Flags needed for both GMP and/or MPFR
AC_SUBST(gmplibs)
AC_SUBST(gmpinc)
+AC_SUBST(extra_mpfr_configure_flags)
# Allow host libstdc++ to be specified for static linking with PPL.
AC_ARG_WITH(host-libstdcxx, [ --with-host-libstdcxx=L Use linker arguments L to link with libstdc++