summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjason <jason@138bc75d-0d04-0410-961f-82ee72b054a4>2015-05-21 15:12:35 +0000
committerjason <jason@138bc75d-0d04-0410-961f-82ee72b054a4>2015-05-21 15:12:35 +0000
commit45b5d9f58b1c500a478b86e028c277c1c879451d (patch)
treec28aed42a444d33939b48f99079c4e4173b2593c /configure.ac
parente1c75243a5ab74297e21b8f6e49b723392da8ad8 (diff)
downloadgcc-45b5d9f58b1c500a478b86e028c277c1c879451d.tar.gz
* configure.ac: Add -std=c++98 to stage1_cxxflags.
* Makefile.tpl (STAGE1_CXXFLAGS): And substitute it. * Makefile.in, configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@223487 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4da04b76fdf..5808eda41aa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3476,8 +3476,15 @@ case $build in
*) stage1_cflags="-g -J" ;;
esac ;;
esac
+stage1_cxxflags='$(STAGE1_CFLAGS)'
+if test "$GCC" = yes; then
+ # Build stage 1 in C++98 mode to ensure that a C++98 compiler can still
+ # start the bootstrap.
+ stage1_cxxflags="$stage1_cxxflags -std=c++98"
+fi
AC_SUBST(stage1_cflags)
+AC_SUBST(stage1_cxxflags)
# Enable --enable-checking in stage1 of the compiler.
AC_ARG_ENABLE(stage1-checking,