summaryrefslogtreecommitdiff
path: root/c++tools/configure.ac
diff options
context:
space:
mode:
authorNathan Sidwell <nathan@acm.org>2020-12-16 11:44:42 -0800
committerNathan Sidwell <nathan@acm.org>2020-12-16 11:57:31 -0800
commit3f78c8cb7f0e025a61734af8d9b9ad70e1b66e40 (patch)
treed5ecca3cab502afcd21db4394fd28bae60b778a6 /c++tools/configure.ac
parent4d4f82959aa0802611f1183389c4c74d22431e49 (diff)
downloadgcc-3f78c8cb7f0e025a61734af8d9b9ad70e1b66e40.tar.gz
c++tools: fix install-strip [PR 98328]
I'd missed an install-strip rule in c++tools. Here it is, cribbed from gcc/ subdir. c++tools/ * Makefile.in (INSTALL): Replace with ... (INSTALL_PROGRAM): ... this. (INSTALL_STRIP_PROGRAM): New. (install-strip): New target. (install): Use INSTALL_PROGRAM. * configure.ac: Add INSTALL_PROGRAM. * configure: Regenerated.
Diffstat (limited to 'c++tools/configure.ac')
-rw-r--r--c++tools/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/c++tools/configure.ac b/c++tools/configure.ac
index 75773650be7..c5560f68d4d 100644
--- a/c++tools/configure.ac
+++ b/c++tools/configure.ac
@@ -32,6 +32,8 @@ ACX_NONCANONICAL_TARGET
AC_CANONICAL_SYSTEM
AC_PROG_INSTALL
+test -z "$INSTALL_PROGRAM" && INSTALL_PROGRAM='${INSTALL}'
+AC_SUBST(INSTALL_PROGRAM)
AC_PROG_CXX
MISSING=`cd $ac_aux_dir && ${PWDCMD-pwd}`/missing