summaryrefslogtreecommitdiff
path: root/boehm-gc/configure.in
diff options
context:
space:
mode:
authortromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>1999-04-26 14:15:05 +0000
committertromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>1999-04-26 14:15:05 +0000
commit41e6be0dbfb73bfa610c4a62cb2b3f33514dd46b (patch)
tree419bf5af5475ca11cc989d4c67ec026cfeb18980 /boehm-gc/configure.in
parentbfc04c7b1c5c42e6645325bfdfb883afd5efefb9 (diff)
downloadgcc-41e6be0dbfb73bfa610c4a62cb2b3f33514dd46b.tar.gz
libtoolized GC library. See ChangeLog for details.
Also a couple bug fixes: * dyn_load.c (GC_FirstDLOpenedLinkMap): Declare _DYNAMIC as `weak'. * misc.c (GC_init_inner): If QUICK_THREADS defined, compute GC_stackbottom. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@26650 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'boehm-gc/configure.in')
-rw-r--r--boehm-gc/configure.in12
1 files changed, 7 insertions, 5 deletions
diff --git a/boehm-gc/configure.in b/boehm-gc/configure.in
index b3cc7ab79b8..eb37d7b8d3f 100644
--- a/boehm-gc/configure.in
+++ b/boehm-gc/configure.in
@@ -9,6 +9,8 @@ AC_CANONICAL_SYSTEM
BOEHM_CONFIGURE(.)
+AM_PROG_LIBTOOL
+
dnl We use these options to decide which functions to include.
AC_ARG_WITH(target-subdir,
[ --with-target-subdir=SUBDIR Configuring with a cross compiler])
@@ -95,7 +97,7 @@ changequote([,])
GC=boehm)
target_all=
if test "$GC" = "boehm"; then
- target_all=libgcjgc.a
+ target_all=libgcjgc.la
fi
AC_SUBST(target_all)
@@ -117,7 +119,7 @@ case "$TARGET_ECOS" in
*)
AC_DEFINE(ECOS)
CXXINCLUDES="-I${TARGET_ECOS}/include"
- addobjs="$addobjs ecos.o"
+ addobjs="$addobjs ecos.lo"
;;
esac
AC_SUBST(CXX)
@@ -128,10 +130,10 @@ AC_SUBST(CXXINCLUDES)
machdep=
case "$host" in
alpha-*-*)
- machdep="alpha_mach_dep.o"
+ machdep="alpha_mach_dep.lo"
;;
mipstx39-*-elf*)
- machdep="mips_ultrix_mach_dep.o"
+ machdep="mips_ultrix_mach_dep.lo"
AC_DEFINE(STACKBASE, __stackbase)
AC_DEFINE(DATASTART_IS_ETEXT)
;;
@@ -140,7 +142,7 @@ case "$host" in
;;
esac
if test x"$machdep" = x; then
- machdep="mach_dep.o"
+ machdep="mach_dep.lo"
fi
addobjs="$addobjs $machdep"
AC_SUBST(addobjs)