summaryrefslogtreecommitdiff
path: root/boehm-gc/configure.in
diff options
context:
space:
mode:
authortromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>1999-11-01 23:15:51 +0000
committertromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>1999-11-01 23:15:51 +0000
commit9bc8642e1f366a35c305b9abe9e01bf934b584b9 (patch)
tree9c24ba1ebabff472b9caddbff07ef957dbf2c24c /boehm-gc/configure.in
parent79eaf784f16b0e8079d9dca062a0fc959d289d18 (diff)
downloadgcc-9bc8642e1f366a35c305b9abe9e01bf934b584b9.tar.gz
Merged GC 5.0alpha4 with local changes, plus:
* Makefile.in: Rebuilt. * Makefile.am (gctest_LDADD): Added THREADLIB. (TESTS): New macro. * configure: Rebuilt. * configure.in (INCLUDES): New subst. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@30332 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'boehm-gc/configure.in')
-rw-r--r--boehm-gc/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/boehm-gc/configure.in b/boehm-gc/configure.in
index 182277a3cd4..29725423b2a 100644
--- a/boehm-gc/configure.in
+++ b/boehm-gc/configure.in
@@ -62,6 +62,7 @@ if test "$THREADS" = yes; then
fi
INCLUDES=
+THREADLIB=
case "$THREADS" in
no | none | single)
THREADS=none
@@ -81,10 +82,12 @@ case "$THREADS" in
AC_DEFINE(IRIX_THREADS)
;;
esac
+ THREADLIB=-lpthread
;;
qt)
AC_DEFINE(QUICK_THREADS)
INCLUDES="-I${boehm_gc_basedir}/../qthreads"
+ THREADLIB=../qthreads/libgcjcoop.la
;;
decosf1 | irix | mach | os2 | solaris | win32 | dce | vxworks)
AC_MSG_ERROR(thread package $THREADS not yet supported)
@@ -94,6 +97,7 @@ case "$THREADS" in
;;
esac
AC_MSG_RESULT($THREADS)
+AC_SUBST(THREADLIB)
AC_ARG_ENABLE(java-gc,
changequote(<<,>>)dnl