summaryrefslogtreecommitdiff
path: root/boehm-gc/configure.ac
diff options
context:
space:
mode:
authorbryce <bryce@138bc75d-0d04-0410-961f-82ee72b054a4>2005-02-16 04:10:42 +0000
committerbryce <bryce@138bc75d-0d04-0410-961f-82ee72b054a4>2005-02-16 04:10:42 +0000
commit735cc3dd9476a9058e71fc04e4d87f60b5a89b59 (patch)
tree314f8a11ca03d334447c50d10982b23142d3c8de /boehm-gc/configure.ac
parent2e53aef54d8a8913c011eb1567d3b82921628ba3 (diff)
downloadgcc-735cc3dd9476a9058e71fc04e4d87f60b5a89b59.tar.gz
2005-02-15 Bryce McKinlay <mckinlay@redhat.com>
PR libgcj/19823 * configure.host: Set gc_use_mmap on *-linux*. * configure.ac: Define USE_MMAP if gc_use_mmap is set. * include/private/gc_priv.h: Include gc_config.h. * configure, include/gc_config.h.in: Rebuilt. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@95094 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'boehm-gc/configure.ac')
-rw-r--r--boehm-gc/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/boehm-gc/configure.ac b/boehm-gc/configure.ac
index 208a9160872..dfb0e17e261 100644
--- a/boehm-gc/configure.ac
+++ b/boehm-gc/configure.ac
@@ -446,6 +446,10 @@ AC_ARG_ENABLE(gc-debug,
esac
fi])
+if test "${gc_use_mmap}" = "yes"; then
+ AC_DEFINE(USE_MMAP, 1, [use MMAP instead of sbrk to get new memory])
+fi
+
if test -n "$with_cross_host" &&
test x"$with_cross_host" != x"no"; then
toolexecdir='$(exec_prefix)/$(target_noncanonical)'