summaryrefslogtreecommitdiff
path: root/boehm-gc/configure.ac
diff options
context:
space:
mode:
authorbryce <bryce@138bc75d-0d04-0410-961f-82ee72b054a4>2004-08-13 23:05:36 +0000
committerbryce <bryce@138bc75d-0d04-0410-961f-82ee72b054a4>2004-08-13 23:05:36 +0000
commite08a5204e5f7a3c3a15588de39202f9579ba0e79 (patch)
tree863181355c9339e1361dad10263a322aaabe426e /boehm-gc/configure.ac
parent7cde58555127f31ba0a5b2a222c81d160e7168e9 (diff)
downloadgcc-e08a5204e5f7a3c3a15588de39202f9579ba0e79.tar.gz
libjava:
2004-08-13 Bryce McKinlay <mckinlay@redhat.com> * configure.in (GCINCS): Don't use "boehm-cflags". Instead, -I boehm-gc's include dirs. * configure: Rebuilt. * include/boehm-gc.h: Include gc_config.h. boehm-gc: 2004-08-13 Bryce McKinlay <mckinlay@redhat.com> * configure.ac (gc_cflags): Add -Iinclude. (AC_CONFIG_HEADERS): New. Configure gc_config.h header. Don't write DEFS to boehm-cflags file. * configure: Rebuilt. * gcj_mlc.c: Check #ifdef GC_GCJ_SUPPORT after including headers. * specific.c: Check #ifdef GC_LINUX_THREADS after including headers. * include/gc_config_macros.h: Remove backward-compatibility redefinitions of GC_ names. * include/gc.h: Include <gc_config.h>. 2004-08-13 Bryce McKinlay <mckinlay@redhat.com> Import Boehm GC version 6.3. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@85972 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'boehm-gc/configure.ac')
-rw-r--r--boehm-gc/configure.ac11
1 files changed, 4 insertions, 7 deletions
diff --git a/boehm-gc/configure.ac b/boehm-gc/configure.ac
index a99cb901a90..0137ff6519f 100644
--- a/boehm-gc/configure.ac
+++ b/boehm-gc/configure.ac
@@ -37,7 +37,7 @@ _GCC_TOPLEV_NONCANONICAL_TARGET
mkinstalldirs="`cd $ac_aux_dir && ${PWDCMD-pwd}`/mkinstalldirs"
AC_SUBST(mkinstalldirs)
-AM_INIT_AUTOMAKE(gc, 6.1a1, no-define)
+AM_INIT_AUTOMAKE(gc, 6.3, no-define)
# The autoconf 2.5x version of the no-executables hack.
sinclude(../config/no-executables.m4)
@@ -79,7 +79,7 @@ case [$]{gc_basedir} in
*) gc_flagbasedir='[$](top_builddir)/'[$]{gc_basedir} ;;
esac
-gc_cflags="[$]{gc_cflags} -I"'[$](top_builddir)'"/./targ-include -I[$]{gc_flagbasedir}/libc/include"
+gc_cflags="[$]{gc_cflags} -Iinclude -I"'[$](top_builddir)'"/./targ-include -I[$]{gc_flagbasedir}/libc/include"
case "${host}" in
*-*-cygwin32*)
gc_cflags="[$]{gc_cflags} -I[$]{gc_flagbasedir}/../winsup/include"
@@ -480,10 +480,7 @@ else
multilib_arg=
fi
-AC_CONFIG_COMMANDS(boehm-cflags, [
-dnl Put all the -I and -D options in a file.
-echo "$AM_CPPFLAGS $DEFS" > boehm-cflags], [
-DEFS="$DEFS"
-AM_CPPFLAGS="$AM_CPPFLAGS"])
+AC_CONFIG_HEADERS([include/gc_config.h])
+
AC_CONFIG_FILES(Makefile include/Makefile)
AC_OUTPUT