summaryrefslogtreecommitdiff
path: root/boehm-gc/configure.ac
diff options
context:
space:
mode:
authorandreast <andreast@138bc75d-0d04-0410-961f-82ee72b054a4>2006-03-24 17:59:29 +0000
committerandreast <andreast@138bc75d-0d04-0410-961f-82ee72b054a4>2006-03-24 17:59:29 +0000
commit8f2a88edcd09290f720bad664a138483de55af7a (patch)
tree1c791519af09cf9a78419751751cd48e970233eb /boehm-gc/configure.ac
parent164f5b3495c714051ea46b4b388ee92f83c1ea8f (diff)
downloadgcc-8f2a88edcd09290f720bad664a138483de55af7a.tar.gz
2006-03-24 Andreas Tobler <a.tobler@schweiz.ch>
John David Anglin <dave.anglin@nrc-cnrc.gc.ca> * configure.ac (THREADS): Add REENTRANT for *-*-hpux11*. Warn about POSIX threads not being supported for *-*-hpux10*. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@112355 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'boehm-gc/configure.ac')
-rw-r--r--boehm-gc/configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/boehm-gc/configure.ac b/boehm-gc/configure.ac
index 2b9663dec20..69ad5cd3ab9 100644
--- a/boehm-gc/configure.ac
+++ b/boehm-gc/configure.ac
@@ -140,8 +140,8 @@ case "$THREADS" in
AC_DEFINE(GC_AIX_THREADS,1,[support AIX threads])
AC_DEFINE(_REENTRANT,1)
;;
- *-*-hpux*)
- AC_MSG_WARN("Only HP/UX 11 threads are supported.")
+ *-*-hpux11*)
+ AC_MSG_WARN("Only HP-UX 11 POSIX threads are supported.")
AC_DEFINE(GC_HPUX_THREADS,1,[enables support for HP/UX 11 pthreads])
AC_DEFINE(_POSIX_C_SOURCE,199506L,[POSIX version of C Source])
if test "${enable_parallel_mark}" = yes; then
@@ -149,6 +149,11 @@ case "$THREADS" in
fi
AC_DEFINE(THREAD_LOCAL_ALLOC,1)
THREADLIBS="-lpthread -lrt"
+ # HPUX needs REENTRANT for the _r calls.
+ AC_DEFINE(_REENTRANT, 1, [Required define if using POSIX threads])
+ ;;
+ *-*-hpux10*)
+ AC_MSG_WARN("Only HP-UX 11 POSIX threads are supported.")
;;
*-*-freebsd*)
AC_MSG_WARN("FreeBSD does not yet fully support threads with Boehm GC.")