summaryrefslogtreecommitdiff
path: root/boehm-gc/configure.ac
diff options
context:
space:
mode:
authorhboehm <hboehm@138bc75d-0d04-0410-961f-82ee72b054a4>2004-08-28 00:41:41 +0000
committerhboehm <hboehm@138bc75d-0d04-0410-961f-82ee72b054a4>2004-08-28 00:41:41 +0000
commit83488a15eb0da6e008cbe431087635239c52f222 (patch)
tree1700d39f175d8dd7078f737fd9bd0459c9a9f3f6 /boehm-gc/configure.ac
parentbc0c30b70e9e9b45b55e6c096873e4f57a6c776a (diff)
downloadgcc-83488a15eb0da6e008cbe431087635239c52f222.tar.gz
* backgraph.c, gc_priv.h (GC_traverse_back_graph,
GC_print_back_graph_stats): split GC_traverse_back_graph. * backgraph.c: Dynamically grow in_progress_space. * finalize.c (GC_notify_or_invoke_finalizers): also call GC_print_back_graph_stats. * alloc.c, finalize.c, gc_priv.h (GC_generate_random_backtrace_no_gc, GC_print_back_height): Move delarations to header file. * configure.ac: rename --enable-full-debug to --enable-gc-debug. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@86685 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'boehm-gc/configure.ac')
-rw-r--r--boehm-gc/configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/boehm-gc/configure.ac b/boehm-gc/configure.ac
index d14b48b4a86..b98d8fbbc00 100644
--- a/boehm-gc/configure.ac
+++ b/boehm-gc/configure.ac
@@ -426,9 +426,9 @@ if test -n "${with_cross_host}"; then
AC_DEFINE(NO_DEBUGGING)
fi
-AC_ARG_ENABLE(full-debug,
-[ --enable-full-debug include full support for pointer backtracing etc.],
-[ if test "$enable_full_debug" = "yes"; then
+AC_ARG_ENABLE(gc-debug,
+[ --enable-gc-debug include full support for pointer backtracing etc.],
+[ if test "$enable_gc_debug" = "yes"; then
AC_MSG_WARN("Must define GC_DEBUG and use debug alloc. in clients.")
AC_DEFINE(KEEP_BACK_PTRS)
AC_DEFINE(DBG_HDRS_ALL)
@@ -444,8 +444,8 @@ AC_ARG_ENABLE(full-debug,
i[3456]86-*-dgux*)
AC_DEFINE(MAKE_BACK_GRAPH)
;;
- esac ]
- fi)
+ esac
+ fi])
if test -n "$with_cross_host" &&
test x"$with_cross_host" != x"no"; then