summaryrefslogtreecommitdiff
path: root/boehm-gc/configure.ac
diff options
context:
space:
mode:
authorHans Boehm <Hans_Boehm@hp.com>2004-08-28 00:41:41 +0000
committerHans Boehm <hboehm@gcc.gnu.org>2004-08-28 00:41:41 +0000
commit3c1cbf58a609a29362ed15c322d588797f3f4cc5 (patch)
tree1700d39f175d8dd7078f737fd9bd0459c9a9f3f6 /boehm-gc/configure.ac
parent5dc50f2714548eae49af060e8e03414ed94dcf0c (diff)
downloadgcc-3c1cbf58a609a29362ed15c322d588797f3f4cc5.tar.gz
backgraph.c, gc_priv.h (GC_traverse_back_graph, [...]): split GC_traverse_back_graph.
* backgraph.c, gc_priv.h (GC_traverse_back_graph, GC_print_back_graph_stats): split GC_traverse_back_graph. * backgraph.c: Dynamically grow in_progress_space. * finalize.c (GC_notify_or_invoke_finalizers): also call GC_print_back_graph_stats. * alloc.c, finalize.c, gc_priv.h (GC_generate_random_backtrace_no_gc, GC_print_back_height): Move delarations to header file. * configure.ac: rename --enable-full-debug to --enable-gc-debug. * configure: Regenerate. From-SVN: r86685
Diffstat (limited to 'boehm-gc/configure.ac')
-rw-r--r--boehm-gc/configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/boehm-gc/configure.ac b/boehm-gc/configure.ac
index d14b48b4a86..b98d8fbbc00 100644
--- a/boehm-gc/configure.ac
+++ b/boehm-gc/configure.ac
@@ -426,9 +426,9 @@ if test -n "${with_cross_host}"; then
AC_DEFINE(NO_DEBUGGING)
fi
-AC_ARG_ENABLE(full-debug,
-[ --enable-full-debug include full support for pointer backtracing etc.],
-[ if test "$enable_full_debug" = "yes"; then
+AC_ARG_ENABLE(gc-debug,
+[ --enable-gc-debug include full support for pointer backtracing etc.],
+[ if test "$enable_gc_debug" = "yes"; then
AC_MSG_WARN("Must define GC_DEBUG and use debug alloc. in clients.")
AC_DEFINE(KEEP_BACK_PTRS)
AC_DEFINE(DBG_HDRS_ALL)
@@ -444,8 +444,8 @@ AC_ARG_ENABLE(full-debug,
i[3456]86-*-dgux*)
AC_DEFINE(MAKE_BACK_GRAPH)
;;
- esac ]
- fi)
+ esac
+ fi])
if test -n "$with_cross_host" &&
test x"$with_cross_host" != x"no"; then