summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am12
1 files changed, 3 insertions, 9 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index d89e6108..445e77c6 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1348,15 +1348,9 @@ messages::
argarray::
@echo $@
- @case "$(srcdir)" in \
- .) : ;; \
- *) cp "$(srcdir)"/argarray.in . ;; \
- esac
- @TEST=test echo just a test | $(AWK) -f "$(srcdir)"/argarray.awk ./argarray.in - >_$@
- @case "$(srcdir)" in \
- .) : ;; \
- *) rm -f ./argarray.in ;; \
- esac
+ @cp "$(srcdir)"/argarray.in ./argarray.input
+ @TEST=test echo just a test | $(AWK) -f "$(srcdir)"/argarray.awk ./argarray.input - >_$@
+ @rm -f ./argarray.input
@-$(CMP) "$(srcdir)"/$@.ok _$@ && rm -f _$@
regtest::