summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew J. Schorr <aschorr@telemetry-investments.com>2012-03-20 10:46:03 -0400
committerAndrew J. Schorr <aschorr@telemetry-investments.com>2012-03-20 10:46:03 -0400
commitb51edf37c4271bf5ec5dcad9d35169f55e38efa9 (patch)
tree66653936b87078aa96a562e05f66660b4d616d8e /configure.ac
parentcd44d957787e162df4348028c22e8b9621000790 (diff)
downloadgawk-b51edf37c4271bf5ec5dcad9d35169f55e38efa9.tar.gz
- Add new environment variable AWKLIBPATH to use when searching for shared
libraries. - Instead of hardcoding the default ".so" suffix for shared libraries, use autoconf to get the right value for this platform. - Build and install some of the bundled shared library extensions so that they will now be available using the default AWKLIBPATH.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3b0ba330..a7de26af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,6 +67,7 @@ AC_PROG_YACC
AC_PROG_LN_S
AC_PROG_CC
AC_PROG_CPP
+AC_PROG_LIBTOOL
AC_OBJEXT
AC_EXEEXT
@@ -99,6 +100,11 @@ fi
AC_SUBST(CFLAGS)
+# shared library suffix for dynamic loading:
+AC_SUBST(acl_shlibext)
+# default shared library location
+AC_SUBST([pkgextensiondir], ['${pkglibdir}'/$VERSION])
+
dnl checks for systems
AC_ZOS_USS
AC_ISC_POSIX
@@ -357,6 +363,7 @@ AH_BOTTOM([#include "custom.h"])
AC_CONFIG_FILES(Makefile
awklib/Makefile
+ extension/Makefile
doc/Makefile
po/Makefile.in
test/Makefile)