summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 8 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index a009c0b..cd9ae75 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,20 +109,14 @@ AM_CONDITIONAL(BSD, test "$arch" = bsd)
util_linux_ok=yes
if test "$arch" = linux -a "$cross_compiling" != "yes"; then
- AC_MSG_CHECKING([if umount supports --fake --no-canonicalize])
- # exit code of umount is 1 if option is unrecognised, 2 otherwise
- umount --fake --no-canonicalize > /dev/null 2>&1
- if test $? != 1; then
- AC_MSG_RESULT([yes])
- else
- firstline=`umount --fake --no-canonicalize 2>&1 | head -1`
- if test "$firstline" = 'umount: only root can use "--fake" option'; then
- AC_MSG_RESULT([yes])
- else
- AC_MSG_RESULT([$firstline])
- util_linux_ok=no
- fi
- fi
+ AC_MSG_CHECKING([if umount supports --fake --no-canonicalize])
+ if umount --help 2>&1 | grep -q -- "--fake" &&
+ umount --help 2>&1 | grep -q -- "--no-canonicalize"; then
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ util_linux_ok=no
+ fi
fi
AC_CONFIG_FILES([fuse3.pc Makefile lib/Makefile util/Makefile example/Makefile include/Makefile doc/Makefile test/Makefile])