summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorMiklos Szeredi <mszeredi@suse.cz>2012-05-16 16:45:27 +0200
committerMiklos Szeredi <mszeredi@suse.cz>2012-05-16 16:45:27 +0200
commit384496dd02cfd9a74b95d62ce0d23a31a7af3730 (patch)
tree056675b9a2d44cc46673e183a912ab33b2483718 /lib/Makefile.am
parentacc5c79dd60c1c2aa528743394e3a9fad7f5def3 (diff)
downloadfuse-384496dd02cfd9a74b95d62ce0d23a31a7af3730.tar.gz
Fix -pthread in fuse.pc
Linking to a library that uses threads requires the application to be linked with -pthreads otherwise some pthread functions will be linked to stubs in glibc. So move -pthread from Libs.private to Libs in fuse.pc. Reported by Werner Fink
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 010b244..5ca5739 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -36,7 +36,7 @@ libfuse_la_SOURCES = \
$(iconv_source) \
$(mount_source)
-libfuse_la_LDFLAGS = @libfuse_libs@ -version-number 2:9:0 \
+libfuse_la_LDFLAGS = -pthread @libfuse_libs@ -version-number 2:9:0 \
-Wl,--version-script,$(srcdir)/fuse_versionscript
if NETBSD