summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMiklos Szeredi <mszeredi@suse.cz>2010-08-27 17:16:54 +0200
committerMiklos Szeredi <mszeredi@suse.cz>2010-08-27 17:16:54 +0200
commit64222fbcbd3ed227e4f9c68e1acccd7e68218982 (patch)
tree7fd0ce19a909ee39f741e50732f1f97cffe21f22 /configure.in
parent7cc73a47ddbc25666f0fba1872099eb3245ba25e (diff)
downloadfuse-64222fbcbd3ed227e4f9c68e1acccd7e68218982.tar.gz
Add NetBSD support
The bulk of it is just about adding ifdef __NetBSD__ where there is already an ifdef __FreeBSD__ Add a arch=netbsd to deal with NetBSD specifics. I suggests that arch=bsd could be renamed to arch=freebsd NetBSD specific linking with -lperfuse NetBSD patches to lib/mount.c. It turned to be less itrusive to patch mount;c than mount_bsd.c. I suggest mount_bsd.c could be renamed to mount_freebsd.c Patch from Emmanuel Dreyfus
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1664204..9d13f33 100644
--- a/configure.in
+++ b/configure.in
@@ -16,6 +16,7 @@ fi
case $target_os in
*linux*) arch=linux;;
+ *netbsd*) arch=netbsd;;
*bsd*) arch=bsd;;
*) arch=unknown;;
esac
@@ -91,6 +92,7 @@ AC_SUBST(INIT_D_PATH)
AC_SUBST(subdirs2)
AM_CONDITIONAL(LINUX, test "$arch" = linux)
+AM_CONDITIONAL(NETBSD, test "$arch" = netbsd)
AM_CONDITIONAL(BSD, test "$arch" = bsd)
AC_CONFIG_FILES([fuse.pc Makefile lib/Makefile util/Makefile example/Makefile include/Makefile])