summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNikolaus Waxweiler <madigens@gmail.com>2018-05-02 23:19:55 +0100
committerNikolaus Waxweiler <madigens@gmail.com>2018-05-02 23:39:28 +0100
commit660afb5ce81ccf3271ec80b6475ec8b16d862a25 (patch)
treeb0942be38e0caa726b83cb3f489f50ca4ae9c25e /CMakeLists.txt
parent9514959241dec9943a99cd1c8f0c214a5fbb0d91 (diff)
downloadfreetype2-660afb5ce81ccf3271ec80b6475ec8b16d862a25.tar.gz
Unbreak CMake Windows installation
* CMakeLists.txt: Generate ftconfig.h on non-UNIX.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ad8ded0bb..6f3fef7d5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -229,9 +229,12 @@ if (UNIX)
endif ()
string(REPLACE "/undef " "#undef "
FTCONFIG_H "${FTCONFIG_H}")
- file(WRITE "${PROJECT_BINARY_DIR}/include/freetype/config/ftconfig.h"
- "${FTCONFIG_H}")
+else()
+ file(READ "${PROJECT_SOURCE_DIR}/include/freetype/config/ftconfig.h"
+ FTCONFIG_H)
endif ()
+file(WRITE "${PROJECT_BINARY_DIR}/include/freetype/config/ftconfig.h"
+ "${FTCONFIG_H}")
# Create the options file