summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Jing <@CPUcontrol>2022-04-01 08:52:31 +0200
committerWerner Lemberg <wl@gnu.org>2022-04-01 08:55:22 +0200
commit89d5cce58de0ddb6c380272cbf13ba6da0f852ff (patch)
tree05aebfbf12ea9ab1e7c060c10a486e80a5970c5e /CMakeLists.txt
parent695d606ae5c86fef8e1207a859fb3fd0cee5a27f (diff)
downloadfreetype2-89d5cce58de0ddb6c380272cbf13ba6da0f852ff.tar.gz
CMakeLists.txt: Fix `Info.plist` path.
When building a framework using CMake with `add_subdirectory`, CMake must be able to find `freetype-Info.plist` when configuring the framework properties. Fixes #1145.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8d6e16a71..5e3345da4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -491,7 +491,7 @@ if (BUILD_FRAMEWORK)
)
set_target_properties(freetype PROPERTIES
FRAMEWORK TRUE
- MACOSX_FRAMEWORK_INFO_PLIST builds/mac/freetype-Info.plist
+ MACOSX_FRAMEWORK_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/builds/mac/freetype-Info.plist
PUBLIC_HEADER "${PUBLIC_HEADERS}"
XCODE_ATTRIBUTE_INSTALL_PATH "@rpath"
)