summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorkarl <karl>2004-05-14 17:07:14 +0000
committerkarl <karl>2004-05-14 17:07:14 +0000
commit7af5fd0fe2d930e0686dc989c239479bf23d01e2 (patch)
treeebdb74bede6f8806e79f2ce5e9a2375f8867904c /configure.in
parente9f0ddc0f8b3ff1a8419acef3ddad9cc81dc1231 (diff)
downloadfontutils-7af5fd0fe2d930e0686dc989c239479bf23d01e2.tar.gz
checkpoint
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in48
1 files changed, 40 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index a1dbaf5..2dd152f 100644
--- a/configure.in
+++ b/configure.in
@@ -1,10 +1,43 @@
-dnl Process this file with autoconf to produce a configure script.
-AC_INIT(lib/spline.c)
+# Process this file with autoconf to produce a configure script.
+# $Id: configure.in,v 1.3 2004/05/14 17:07:14 karl Exp $
+#
+# This file is free software; as a special exception the author gives
+# unlimited permission to copy and/or distribute it, with or without
+# modifications, as long as this notice is preserved.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
+# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+#
+AC_PREREQ(2.59)# Minimum Autoconf version required.
-dnl Write output here, instead of putting -D's on the command line.
-AC_CONFIG_HEADER(include/c-auto.h)
+AC_INIT([GNU Fontutils], [0.6.90])
+AC_CONFIG_HEADERS(include/c-auto.h)
+AC_CONFIG_SRCDIR([lib/spline.c])
-sinclude(../kpathsea/common.ac)
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_RANLIB
+
+AC_HEADER_DIRENT
+AC_HEADER_STDC
+AC_CHECK_HEADERS(assert.h float.h limits.h memory.h pwd.h stdlib.h \
+ string.h sys/param.h unistd.h)
+
+AC_C_CONST
+
+AC_FUNC_CLOSEDIR_VOID
+
+# This is a GNU libc invention.
+AC_MSG_CHECKING(whether program_invocation_name is predefined)
+AC_CACHE_VAL(kb_cv_var_program_inv_name,
+[AC_TRY_LINK(,
+ [extern char *program_invocation_name; program_invocation_name = "love";],
+ kb_cv_var_program_inv_name=yes, kb_cv_var_program_inv_name=no)])dnl
+AC_MSG_RESULT($kb_cv_var_program_inv_name)
+if test "$kb_cv_var_program_inv_name" = yes; then
+ AC_DEFINE(HAVE_PROGRAM_INVOCATION_NAME)
+fi
# We must have gcc.
[if test -n "$GCC"
@@ -14,7 +47,6 @@ else
echo "so you need to have gcc."
fi]
-AC_FIND_XTRA
-
# This will generate `Makefile'(s), `config.status', and our header file.
-AC_OUTPUT(GNUmakefile doc/Makefile)
+AC_CONFIG_FILES([GNUmakefile doc/Makefile])
+AC_OUTPUT