summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorErik de Castro Lopo <erikd@mega-nerd.com>2014-03-15 16:47:49 +1100
committerErik de Castro Lopo <erikd@mega-nerd.com>2014-03-15 16:47:52 +1100
commit9863998c995ad239aa2e712f8ee84e4813af5211 (patch)
tree630bab0936aae3bd5954625349d722470025c207 /configure.ac
parent7e85023c9f6b336b55f49435f5abbafcb5b5e44c (diff)
downloadflac-9863998c995ad239aa2e712f8ee84e4813af5211.tar.gz
configure.ac : Make --enable-sse the default.
SSE can still be disabled by configuring with --disable-sse but SSE will be enabled by default.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 19320a4e..1f4a8e95 100644
--- a/configure.ac
+++ b/configure.ac
@@ -200,14 +200,14 @@ esac],[debug=false])
AM_CONDITIONAL(DEBUG, test "x$debug" = xtrue)
AC_ARG_ENABLE(sse,
-AC_HELP_STRING([--enable-sse], [Enable SSE support by asserting that the OS supports SSE instructions]),
+AC_HELP_STRING([--disable-sse], [Disable SSE if the OS does not support SSE instructions]),
[case "${enableval}" in
- yes) sse_os=true ;;
- no) sse_os=false ;;
+ yes) sse_os=yes ;;
+ no) sse_os=no ;;
*) AC_MSG_ERROR(bad value ${enableval} for --enable-sse) ;;
-esac],[sse_os=false])
+esac],[sse_os=yes])
AM_CONDITIONAL(FLaC__SSE_OS, test "x$sse_os" = xtrue)
-if test "x$sse_os" = xtrue ; then
+if test "x$sse_os" = xyes ; then
AC_DEFINE(FLAC__SSE_OS)
AH_TEMPLATE(FLAC__SSE_OS, [define if your operating system supports SSE instructions])
fi
@@ -524,6 +524,7 @@ if test x$ac_cv_c_compiler_gnu = xyes ; then
echo " GCC version : ......................... ${GCC_VERSION}"
fi
echo " Compiler is Clang : ................... ${xiph_cv_c_compiler_clang}"
+ echo " SSE optimizations : ................... ${sse_os}"
echo " Asm optimizations : ................... ${asm_optimisation}"
echo " Ogg/FLAC support : .................... ${have_ogg}"
echo