summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@baserock.org>2013-02-22 14:03:40 +0000
committer <>2013-02-28 22:06:04 +0000
commit3b49db406667ee7189b9ea69b9d9e0bdcc43c5b7 (patch)
tree13be3ebf87cab39e68c3e4dbb1367151ac0e8a6f /tests/Makefile.am
downloadfile-3b49db406667ee7189b9ea69b9d9e0bdcc43c5b7.tar.gz
Imported from /home/lorry/working-area/delta_file/file-5.13.tar.gz.file-5.13baserock/morph
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..0665c7b
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,11 @@
+check_PROGRAMS = test
+test_LDADD = $(top_builddir)/src/libmagic.la
+test_CPPFLAGS = -I$(top_srcdir)/src
+
+EXTRA_DIST = \
+ gedcom.magic gedcom.testfile gedcom.result
+
+T = $(top_srcdir)/tests
+check-local:
+ MAGIC=$(top_builddir)/magic/magic ./test
+ for i in $T/*.testfile; do MAGIC=$T/$${i%%.testfile}.magic $(top_builddir)/tests/test $T/$$i $T/$${i%%.testfile}.result; done