summaryrefslogtreecommitdiff
path: root/src/benchmarks/eo/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/benchmarks/eo/Makefile.am')
-rw-r--r--src/benchmarks/eo/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/benchmarks/eo/Makefile.am b/src/benchmarks/eo/Makefile.am
new file mode 100644
index 0000000000..a2aac483f0
--- /dev/null
+++ b/src/benchmarks/eo/Makefile.am
@@ -0,0 +1,36 @@
+
+MAINTAINERCLEANFILES = Makefile.in
+
+AM_CPPFLAGS = \
+-I$(top_builddir)/src/lib/efl \
+-I$(top_srcdir)/src/lib/eina \
+-I$(top_srcdir)/src/lib/eo \
+-I$(top_builddir)/src/lib/eina \
+-I$(top_builddir)/src/lib/eo \
+@EO_CFLAGS@
+
+EXTRA_PROGRAMS = eo_bench
+
+benchmark: eo_bench
+
+eo_bench_SOURCES = \
+class_simple.c \
+class_simple.h \
+eo_bench.c \
+eo_bench.h \
+eo_bench_callbacks.c \
+eo_bench_eo_do.c \
+eo_bench_eo_add.c
+
+eo_bench_LDADD = \
+$(top_builddir)/src/lib/eo/libeo.la \
+$(top_builddir)/src/lib/eina/libeina.la \
+@EO_LDFLAGS@ \
+-lpthread
+
+clean-local:
+ rm -rf *.gcno ..\#..\#src\#*.gcov *.gcda
+
+if ALWAYS_BUILD_EXAMPLES
+noinst_PROGRAMS = $(EXTRA_PROGRAMS)
+endif