summaryrefslogtreecommitdiff
path: root/doc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build11
1 files changed, 1 insertions, 10 deletions
diff --git a/doc/meson.build b/doc/meson.build
index 18b9aeecf4..5ad389828c 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -104,8 +104,6 @@ widget_preview_eps = custom_target('widget_preview_prefs_epc',
shot_sh = find_program('shot.sh')
tar = find_program('tar')
-efl_copy = find_program('efl_copy.sh')
-
foreach text_filter_property : text_filter_properties
text = text_filter_property[0]
font = text_filter_property[1]
@@ -182,17 +180,10 @@ doc_target += custom_target('doxygen',
build_by_default: false
)
-# This is not pretty but meson does not seem to allow wildcards in plain cp commands
-copy_images = custom_target('documentation images',
- command: [efl_copy, '-rf', join_paths(meson.current_source_dir(), 'img', '*.png'), 'html'],
- output: ['empty_img_copy'],
- build_by_default: false
-)
-
compress_target = custom_target('package_doc_tar',
command: [tar, '-C', meson.build_root(), '--xz', '-cf', 'efl-'+meson.project_version()+'-doc.tar.xz', 'html', 'man'],
output: 'efl-'+meson.project_version()+'-doc.tar.xz',
- depends: [doc_target, copy_images],
+ depends: [doc_target],
build_by_default: false
)