summaryrefslogtreecommitdiff
path: root/src/lib/emotion/meson.build
diff options
context:
space:
mode:
authorStefan Schmidt <s.schmidt@samsung.com>2020-05-18 17:46:55 +0200
committerMarcel Hollerbach <mail@marcel-hollerbach.de>2020-05-26 10:15:21 +0200
commit3ca9d7282515c688f79aa7d6db34eaf33804096f (patch)
tree302b8aec11f4aeed23dd43397180b294311317af /src/lib/emotion/meson.build
parent59127058afd3f1259a0dfc438ca387fa02b72ccc (diff)
downloadefl-3ca9d7282515c688f79aa7d6db34eaf33804096f.tar.gz
build: lib: harmonize the use of package_c_args in all libs
Add it to subprojects which are not using it and remove and old ELEMENTARY_BUILD define we no longer use. This allows us to have a central place in the main meson.build file to set this variable. Reviewed-by: Marcel Hollerbach <mail@marcel-hollerbach.de> Reviewed-by: Vincent Torri <vincent.torri@gmail.com> Reviewed-by: João Paulo Taylor Ienczak Zanette <joao.tiz@expertisesolutions.com.br> Differential Revision: https://phab.enlightenment.org/D11854
Diffstat (limited to 'src/lib/emotion/meson.build')
-rw-r--r--src/lib/emotion/meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/lib/emotion/meson.build b/src/lib/emotion/meson.build
index 6f2717dfa6..e779a39248 100644
--- a/src/lib/emotion/meson.build
+++ b/src/lib/emotion/meson.build
@@ -44,17 +44,18 @@ if get_option('eeze') == true
emotion_deps += [eeze]
endif
+# Save in extra variable here to pass to edje_externa
+emotion_package_c_args = package_c_args
+
emotion_lib = library('emotion',
emotion_src, pub_eo_file_target, priv_eo_file_target,
dependencies: emotion_deps + emotion_pub_deps,
include_directories : config_dir + [include_directories('.')],
install: true,
- c_args : package_c_args,
+ c_args : emotion_package_c_args,
version : meson.project_version()
)
-emotion_package_c_args = package_c_args
-
emotion = declare_dependency(
include_directories: [include_directories('.')],
link_with: emotion_lib,