summaryrefslogtreecommitdiff
path: root/src/bin/elementary/meson.build
diff options
context:
space:
mode:
authorDaniel Zaoui <daniel.zaoui@samsung.com>2018-10-21 09:37:12 +0300
committerDaniel Zaoui <daniel.zaoui@yahoo.com>2018-10-21 09:38:25 +0300
commit2d2055edd750d9f9fa425b3c260b010781e8734c (patch)
tree9818e15d91d5d09ae65f62924e9b33df2b2bb689 /src/bin/elementary/meson.build
parent7baac6a5567d2956ac15ffb2693b3b6c159a9013 (diff)
downloadefl-2d2055edd750d9f9fa425b3c260b010781e8734c.tar.gz
Meson: link elementary_test with rdynamic
Summary: This is needed to let dlsym extract the efl_main/main... symbols. For example, the Exactness player needs it to launch a given binary. If this option is not provided during the linkage of the binary, the player won't be able to run it. Test Plan: exactness_play -t <path to exactness scenarios>/radio.rec -- elementary_test -to radio Reviewers: bu5hm4n Reviewed By: bu5hm4n Subscribers: cedric, #reviewers, #committers Tags: #efl Differential Revision: https://phab.enlightenment.org/D7178
Diffstat (limited to 'src/bin/elementary/meson.build')
-rw-r--r--src/bin/elementary/meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/bin/elementary/meson.build b/src/bin/elementary/meson.build
index 58f82c1925..ec2ea225f0 100644
--- a/src/bin/elementary/meson.build
+++ b/src/bin/elementary/meson.build
@@ -163,7 +163,8 @@ elementary_test = executable('elementary_test',
'-Delementary_test_BIN_DIR="'+dir_bin+'"',
'-Delementary_test_LIB_DIR="'+dir_lib+'"',
'-Delementary_test_DATA_DIR="'+join_paths(dir_data,'elementary')+'"'
- ]
+ ],
+ link_args: '-rdynamic'
)
elementary_config_src = [
@@ -175,6 +176,7 @@ elementary_config = executable('elementary_config',
dependencies: [elementary] + elementary_deps + elementary_pub_deps,
install: true,
c_args : package_c_args,
+ link_args: '-rdynamic'
)
elementary_quicklaunch_src = [
@@ -186,6 +188,7 @@ elementary_quicklaunch = executable('elementary_quicklaunch',
dependencies: [elementary] + elementary_deps + elementary_pub_deps,
install: true,
c_args : package_c_args,
+ link_args: '-rdynamic'
)
elementary_codegen_src = [
@@ -197,6 +200,7 @@ elementary_codegen = executable('elementary_codegen',
dependencies: [elementary] + elementary_deps + elementary_pub_deps,
install: true,
c_args : package_c_args,
+ link_args: '-rdynamic'
)
elm_prefs_cc_src = [
@@ -214,6 +218,7 @@ elm_prefs_cc = executable('elm_prefs_cc',
dependencies: [elementary] + elementary_deps + elementary_pub_deps,
install: true,
c_args : package_c_args,
+ link_args: '-rdynamic'
)
elementary_run_src = [
@@ -225,4 +230,5 @@ elementary_run = executable('elementary_run',
dependencies: [elementary] + elementary_deps + elementary_pub_deps,
install: true,
c_args : package_c_args,
+ link_args: '-rdynamic'
)