summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@osg.samsung.com>2016-03-31 16:22:04 +0200
committerStefan Schmidt <stefan@osg.samsung.com>2016-03-31 16:29:32 +0200
commit0a03e633500466b86cca3b7a5f088735afd7cb56 (patch)
treee1738c8816d58859713b8af174a7464c53a665a4 /src/Makefile.am
parent08761352602f81962a09f7175dc50b1c3111c2dd (diff)
downloadefl-0a03e633500466b86cca3b7a5f088735afd7cb56.tar.gz
build: keep our CLEANFILES tidy to avoid argument list too long during clean
We have been putting the generated eo files and BUILT_SOURCES into CLEANFILES several times. So far this have not been a real problem but with the elm merge and more and more eo files showing up this did explode recently. During make distcheck a lot of files kept being around and make complained about them. It took some digging to find the arguments list to long error. If you want details on this great limitation have a look here: http://www.linuxjournal.com/article/6060 In our case we have been lucky enough that we just appened many files over and over again. Not doing that solves the issue for now. My testing showed no problems but if I missed something let me know. Fixes T3386
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c256c4f909..da975e226e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -100,6 +100,9 @@ endif
include Makefile_Eolian_Js.am
include Makefile_Efl_Js.am
+# Make sure all generated files getting cleaned up
+CLEANFILES += $(BUILT_SOURCES)
+
.PHONY: benchmark examples
BENCHMARK_SUBDIRS = \