summaryrefslogtreecommitdiff
path: root/meson_options.txt
diff options
context:
space:
mode:
authorWonki Kim <wonki_.kim@samsung.com>2019-01-09 14:36:09 +0000
committerMarcel Hollerbach <mail@marcel-hollerbach.de>2019-01-10 10:57:42 +0100
commit8d58ef48bdad37d42272d28008f538324c9a01fe (patch)
tree4e288fb38e2176d39ba4e8c6cb8cce66a1ffc9fe /meson_options.txt
parent2c2f93dc1a8114695d5d72d7ea850995e88f9e56 (diff)
downloadefl-8d58ef48bdad37d42272d28008f538324c9a01fe.tar.gz
meson: modify options for enabling the bindings
bindings are added as subdir by foreaching a array defined in meson.build at root. then meson checks a option which has the same name of the binding. this patch appends a new option for selecting bindings to build. [howto] *as-is meson build.asis/ -Dmono=false -Dcxx=true ninja -C build.asis/ *to-be menson build.tobe/ -Dbindings=luajit,cxx ninja -C build.tobe/ it is imposibble to use this wrongly because meson raise a error if arguments are not in a predefined list that described in meson_options.txt. for more information, refer to https://mesonbuild.com/Build-options.html and also take a look at meson_options.txt please. Differential Revision: https://phab.enlightenment.org/D7563
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt21
1 files changed, 5 insertions, 16 deletions
diff --git a/meson_options.txt b/meson_options.txt
index e24f999ee4..563794e6a4 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -310,22 +310,11 @@ option('nls',
description: 'enable localization: (default=true)'
)
-option('luajit',
- type: 'boolean',
- value: true,
- description: 'Flag for handling lua bindings'
-)
-
-option('cxx',
- type: 'boolean',
- value: true,
- description: 'Flag for handling cxx bindings'
-)
-
-option('mono',
- type: 'boolean',
- value: false,
- description: 'Flag for handling c# bindings'
+option('bindings',
+ type : 'array',
+ choices : ['luajit', 'cxx', 'mono'],
+ value : ['luajit', 'cxx'],
+ description : 'Add values here to enable the bindings',
)
option('native-arch-optimization',