summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman) <raster@rasterman.com>2018-11-11 09:15:14 +0000
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2018-11-11 09:15:14 +0000
commitf92bf3d8cdf4aa9c00c225ecb7c155516b5de91e (patch)
tree76a57fea9682d08836cd0a76a2922c099d238b07 /meson.build
parent791cd5b157ed2ae9c5bd9e2816530cd52c55cfa2 (diff)
downloadefl-f92bf3d8cdf4aa9c00c225ecb7c155516b5de91e.tar.gz
meson - define WORDS_BIGENDIAN if on big endian
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 8ec9b5e06a..6e1a574ca8 100644
--- a/meson.build
+++ b/meson.build
@@ -120,6 +120,11 @@ cpu_altivec = false
evas_opt_c_args = [ ]
machine_c_args = [ ]
compiler = meson.get_compiler('c')
+
+if host_machine.endian() == 'big'
+ config_h.set10('WORDS_BIGENDIAN', true)
+endif
+
if host_machine.cpu_family() == 'x86' or host_machine.cpu_family() == 'x86_64'
if compiler.has_header('immintrin.h') == true
if (get_option('cpu-mmx') == true)