summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarcel Hollerbach <mail@marcel-hollerbach.de>2018-10-17 13:04:07 +0200
committerMarcel Hollerbach <mail@marcel-hollerbach.de>2018-10-24 12:05:58 +0200
commit6f9761ff54cf1c6e3d90407beefeee50118d6a9c (patch)
treef991b0659b22a68cf7e5ee3fd3010e631a359fae /meson.build
parente85311c99286988f98ce081148f6f9e298086c2d (diff)
downloadefl-6f9761ff54cf1c6e3d90407beefeee50118d6a9c.tar.gz
meson: time for the c-sharp build
The tests are added and build. For running C# code please see the wiki. you can enable -Dmono=true Differential Revision: https://phab.enlightenment.org/D7203
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 83e9dc8117..b69113efa3 100644
--- a/meson.build
+++ b/meson.build
@@ -1,4 +1,4 @@
-project('efl', ['c','cpp'],
+project('efl', ['c','cpp', 'cs'],
version: '1.21.99',
default_options : ['buildtype=plain'],
meson_version : '>=0.46'
@@ -313,7 +313,7 @@ subdir(join_paths('src', 'bin', 'efl'))
subdir(join_paths('src', 'generic', 'evas'))
subdir(join_paths('src', 'generic', 'emotion'))
-bindings = ['luajit', 'cxx']
+bindings = ['luajit', 'cxx', 'mono']
foreach binding : bindings
if get_option(binding)