summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarcel Hollerbach <mail@marcel-hollerbach.de>2018-10-04 18:29:56 +0200
committerMarcel Hollerbach <mail@marcel-hollerbach.de>2018-10-05 13:40:29 +0200
commit347dc66ba9c841f5e1dfda778ea79757acbdd621 (patch)
treeb60f3a6d8afa9411a5f405ebbf993152c71a012b /meson.build
parent124fbd3fa3464a4fe8cb436666f2cdc09d793162 (diff)
downloadefl-347dc66ba9c841f5e1dfda778ea79757acbdd621.tar.gz
meson: unify system properties
this unifies the system types into 4 boolean flags This fixes the fact that meson changed the system string accross versions. Differential Revision: https://phab.enlightenment.org/D7144
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 8 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 0f026b3c5c..0a8870eea6 100644
--- a/meson.build
+++ b/meson.build
@@ -108,15 +108,20 @@ bsd = ['bsd', 'freebsd', 'dragonfly', 'netbsd']
linux = ['linux']
osx = ['darwin']
-if linux.contains(target_machine.system()) or bsd.contains(target_machine.system())
+sys_linux = linux.contains(target_machine.system())
+sys_bsd = bsd.contains(target_machine.system())
+sys_windows = windows.contains(target_machine.system())
+sys_osx = osx.contains(target_machine.system())
+
+if sys_linux == true or sys_bsd == true
sys_lib_extension = 'so'
sys_exe_extension = ''
sys_mod_extension = 'so'
-elif windows.contains(target_machine.system())
+elif sys_windows == true
sys_lib_extension = 'dll'
sys_exe_extension = 'exe'
sys_mod_extension = 'dll'
-elif osx.contains(target_machine.system())
+elif sys_osx == true
sys_lib_extension = 'dylib'
sys_exe_extension = ''
sys_mod_extension = 'dylib'