summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarcel Hollerbach <mail@marcel-hollerbach.de>2018-10-03 18:06:33 +0200
committerMarcel Hollerbach <mail@marcel-hollerbach.de>2018-10-03 18:07:44 +0200
commit22d7cd12430bf4817d5ae38fa970988660f33d60 (patch)
tree8175629bf720bf8b764a0b60f091c17889b7ac6b /meson.build
parentc68ac6c1b7d77774f888a6f4155a615b49d2fefc (diff)
downloadefl-22d7cd12430bf4817d5ae38fa970988660f33d60.tar.gz
meson: install compat ethumb_client.pc file
in autotools this was not having the same naming convetion than in meson right now. This installs a duplicated .pc file, so the one with the different name can be dropped at some point. Fix terminology compilation. Differential Revision: https://phab.enlightenment.org/D7132
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 72c48b8486..0f026b3c5c 100644
--- a/meson.build
+++ b/meson.build
@@ -267,6 +267,15 @@ foreach package : subprojects
libraries : tmp_pub_deps,
requires : package[8],
)
+ if package_name == 'ethumb_client'
+ pkgconfig.generate(tmp_lib,
+ name : package_name,
+ subdirs : package_version_name,
+ version : version_major + '.' + version_minor,
+ libraries : tmp_pub_deps,
+ requires : package[8],
+ )
+ endif
endif
else
message(package_name+' disabled!')