summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorVincent Torri <vincent.torri@gmail.com>2020-06-18 14:35:46 +0100
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2020-06-18 14:36:48 +0100
commitf04316e3f0395e746b3047344d398ea281e0880e (patch)
tree4aa1a33b2dd87d47d63c8b3564561476ab69418c /meson.build
parentfbd3bc626216694a1eb43bbe0462692c56b5b82e (diff)
downloadefl-f04316e3f0395e746b3047344d398ea281e0880e.tar.gz
meson: add Solaris support
Summary: Add Solaris support for meson Test Plan: test on OpenIndiana Reviewers: raster, bu5hm4n, stefan_schmidt Reviewed By: raster, stefan_schmidt Subscribers: alarcher, stefan_schmidt, bu5hm4n, cedric, #reviewers, #committers Tags: #efl Differential Revision: https://phab.enlightenment.org/D11973
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index af9e8b031e..b2c2d7ff5d 100644
--- a/meson.build
+++ b/meson.build
@@ -48,11 +48,13 @@ windows = ['windows', 'cygwin']
bsd = ['bsd', 'freebsd', 'dragonfly', 'netbsd', 'openbsd']
linux = ['linux']
osx = ['darwin']
+sun = ['sunos']
sys_linux = linux.contains(host_machine.system())
sys_bsd = bsd.contains(host_machine.system())
sys_windows = windows.contains(host_machine.system())
sys_osx = osx.contains(host_machine.system())
+sys_sun = sun.contains(host_machine.system())
module_files = []
evas_loader_map = []
@@ -126,6 +128,11 @@ foreach lang : ['c', 'objc', 'cpp']
endif
endforeach
+if sys_sun == true
+# for getpwuid_r()
+ add_global_arguments('-D_POSIX_PTHREAD_SEMANTICS', language: 'c')
+endif
+
config_h = configuration_data()
config_h.set_quoted('MODULE_ARCH', version_name)
config_h.set_quoted('PACKAGE', meson.project_name())
@@ -200,7 +207,7 @@ endif
config_dir = [include_directories('.')]
eolian_include_directories = []
-if sys_linux == true or sys_bsd == true
+if sys_linux == true or sys_bsd == true or sys_sun == true
sys_lib_extension = 'so'
sys_exe_extension = ''
sys_mod_extension = 'so'