summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGustavo Sverzut Barbieri <barbieri@profusion.mobi>2016-09-20 15:00:17 -0300
committerGustavo Sverzut Barbieri <barbieri@profusion.mobi>2016-09-20 15:00:48 -0300
commitf0f9c5d24a0a261367371fd420bc3a3e04b5285f (patch)
treec7ea93c07b56ade65c764d7d85ba389fa980904f /configure.ac
parent132ae9683c242b695d1bb3050c09f83386d0667d (diff)
downloadefl-f0f9c5d24a0a261367371fd420bc3a3e04b5285f.tar.gz
libproxy: dlopen() and make it runtime optional.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 0 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index a403484603..d0b9962823 100644
--- a/configure.ac
+++ b/configure.ac
@@ -224,7 +224,6 @@ case "$host_os" in
;;
freebsd*)
have_freebsd="yes"
- want_libproxy="yes"
ELM_UNIX_DEF="#define"
;;
darwin*)
@@ -235,7 +234,6 @@ case "$host_os" in
have_linux="yes"
have_systemd_pkg="auto"
want_systemd="yes"
- want_libproxy="yes"
ELM_UNIX_DEF="#define"
;;
*)
@@ -3034,16 +3032,6 @@ EFL_LIB_START([Ecore_Con])
### Default values
-AC_ARG_ENABLE([libproxy],
- [AS_HELP_STRING([--enable-libproxy],[Enable libproxy support. @<:@default=enabled@:>@])],
- [
- if test "x${enableval}" = "xyes" ; then
- want_libproxy="yes"
- else
- want_libproxy="no"
- fi
- ])
-
want_ecore_con_local_sockets="yes"
want_ecore_con_abstract_sockets="yes"
@@ -3080,7 +3068,6 @@ EFL_INTERNAL_DEPEND_PKG([ECORE_CON], [emile])
EFL_ADD_LIBS([ECORE_CON], [-lm])
EFL_OPTIONAL_DEPEND_PKG([ECORE_CON], [${want_systemd}], [SYSTEMD], [libsystemd])
-EFL_OPTIONAL_DEPEND_PKG([ECORE_CON], [${want_libproxy}], [LIBPROXY], [libproxy-1.0])
EFL_ADD_FEATURE([ECORE_CON], [local-sockets], [${want_ecore_con_local_sockets}])
EFL_ADD_FEATURE([ECORE_CON], [abstract-sockets], [${want_ecore_con_abstract_sockets}])