summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCedric Bail <cedric@osg.samsung.com>2016-07-28 21:02:51 -0700
committerCedric Bail <cedric@osg.samsung.com>2016-07-28 21:03:12 -0700
commit3a9d43ff3131147b43af5c2ff7f6436cefe31bdc (patch)
tree8243dad11b57b248cca24b9f480ef84e36cd22de /configure.ac
parent351c2007f6d06d5463cae431f54618fa4410eeea (diff)
downloadefl-3a9d43ff3131147b43af5c2ff7f6436cefe31bdc.tar.gz
eina: add back option lost at some point for debugging.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 618ccb488a..630417a0b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -894,6 +894,16 @@ AC_ARG_ENABLE([magic-debug],
],
[have_magic_debug="yes"])
+AC_ARG_ENABLE([debug-threads],
+ [AS_HELP_STRING([--enable-debug-threads], [enable debugging of eina threads @<:@default=disabled@:>@])],
+ [
+ if test "x${enableval}" = "xyes" ; then
+ want_debug_threads="yes"
+ else
+ want_debug_threads="no"
+ fi
+ ])
+
EINA_CONFIG([MAGIC_DEBUG], [test "x${have_magic_debug}" = "xyes"])
AC_ARG_WITH([xattr-tests-path],