summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGustavo Sverzut Barbieri <barbieri@profusion.mobi>2016-09-19 03:19:16 -0300
committerGustavo Sverzut Barbieri <barbieri@profusion.mobi>2016-09-19 10:01:51 -0300
commit0d478c301f49fccfd94a107c060696f79490c30d (patch)
tree788dcd1b0fa3dd956a0a73e2d3e48834e4847ac1 /configure.ac
parent696692ab90d055b67f48490f6216a010e35844a3 (diff)
downloadefl-0d478c301f49fccfd94a107c060696f79490c30d.tar.gz
efl_net_dialer_tcp: use libproxy settings.
libproxy allows various means to configure a proxy, will load from gnome and kde configuration settings, envvars, macos and even windows registry. curl still doesn't use it, but we can make that later.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d0b9962823..a403484603 100644
--- a/configure.ac
+++ b/configure.ac
@@ -224,6 +224,7 @@ case "$host_os" in
;;
freebsd*)
have_freebsd="yes"
+ want_libproxy="yes"
ELM_UNIX_DEF="#define"
;;
darwin*)
@@ -234,6 +235,7 @@ case "$host_os" in
have_linux="yes"
have_systemd_pkg="auto"
want_systemd="yes"
+ want_libproxy="yes"
ELM_UNIX_DEF="#define"
;;
*)
@@ -3032,6 +3034,16 @@ EFL_LIB_START([Ecore_Con])
### Default values
+AC_ARG_ENABLE([libproxy],
+ [AS_HELP_STRING([--enable-libproxy],[Enable libproxy support. @<:@default=enabled@:>@])],
+ [
+ if test "x${enableval}" = "xyes" ; then
+ want_libproxy="yes"
+ else
+ want_libproxy="no"
+ fi
+ ])
+
want_ecore_con_local_sockets="yes"
want_ecore_con_abstract_sockets="yes"
@@ -3068,6 +3080,7 @@ EFL_INTERNAL_DEPEND_PKG([ECORE_CON], [emile])
EFL_ADD_LIBS([ECORE_CON], [-lm])
EFL_OPTIONAL_DEPEND_PKG([ECORE_CON], [${want_systemd}], [SYSTEMD], [libsystemd])
+EFL_OPTIONAL_DEPEND_PKG([ECORE_CON], [${want_libproxy}], [LIBPROXY], [libproxy-1.0])
EFL_ADD_FEATURE([ECORE_CON], [local-sockets], [${want_ecore_con_local_sockets}])
EFL_ADD_FEATURE([ECORE_CON], [abstract-sockets], [${want_ecore_con_abstract_sockets}])