summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman) <raster@rasterman.com>2015-06-24 19:24:21 +0900
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2015-06-24 19:28:17 +0900
commit5abfefe99ea290191ef59f840b11c64fb9792edb (patch)
treef156bef3d97b775df535604fba800fa7f2d2cf2e /Makefile.am
parentc6011926bad960136af132a97b54cb38199638fe (diff)
downloadefl-5abfefe99ea290191ef59f840b11c64fb9792edb.tar.gz
efl - efreetd service move from dbus session bus to ecore ipc
this fixes warnings about no efreet dbus session bus in non session environments as brought up on the mailing lists with: Subject: Re: [E-devel] [EGIT] [core/efl] master 01/01: edje: unset efreet cache update flag to prevent dbus connections this moves all of efreetd client and server to ecore ipc, with client auto-launching efreetd if not found as a service and trying for up to 500ms to connect. efreetd times out on last connection or no connections after 10sec so it wont hang around forever if not in use. it seems to work in my testing, so let me know if there is an issue. @fix
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d02db5e5b7..e172405033 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -383,13 +383,11 @@ cmakeconfig/EmileConfigVersion.cmake
servicedir = @dbusservicedir@
service_DATA = \
-dbus-services/org.enlightenment.Efreet.service \
dbus-services/org.enlightenment.Ethumb.service
if HAVE_SYSTEMD_USER_SESSION
systemdunitsdir = @USER_SESSION_DIR@
systemdunits_DATA = \
-systemd-services/efreet.service \
systemd-services/ethumb.service
endif
EXTRA_DIST += $(systemdunits_DATA)