summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGustavo Sverzut Barbieri <barbieri@profusion.mobi>2017-01-27 12:38:52 -0200
committerGustavo Sverzut Barbieri <barbieri@profusion.mobi>2017-01-27 12:52:14 -0200
commit525d1e062975f732c54e40074d15500cdcaa4cb4 (patch)
treeb074fd0fef65f756ebbe2d5993313cbafcb882bc /CMakeLists.txt
parent28960d78513f95204a75e86af817efb3a343e6b0 (diff)
downloadefl-525d1e062975f732c54e40074d15500cdcaa4cb4.tar.gz
cmake: add EFL_SUPPORT_LIB() and simplify/speedup its usage.
generate a static library for src/static_libs and use that as LIBRARIES for the actual library, for those such as rg_etc that are used multiple times will even speed up the final build by compiling only once. Although not used, they can be made into shared libraries that would go inside /usr/lib/efl/support/v-1.19/libname.so
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b9cebbec7f..b3fe86b0c1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -31,6 +31,12 @@ include_directories(
include(${CMAKE_SOURCE_DIR}/cmake/config/common.cmake)
+EFL_SUPPORT_LIB(lz4)
+EFL_SUPPORT_LIB(draw)
+EFL_SUPPORT_LIB(freetype)
+EFL_SUPPORT_LIB(rg_etc)
+EFL_SUPPORT_LIB(triangulator)
+
EFL_LIB(eina)
EFL_LIB(eolian)
EFL_LIB(eo)